# CVE-2025-65548: Denial of service in n/a

> Attackers can exhaust mint disk space by creating tokens with oversized preimages, causing denial of service.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-xwrw-2crp-46q4, PYSEC-2025-89

## What is CVE-2025-65548?

CVE-2025-65548 is a critical denial of service vulnerability in n/a, published on 8 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NUT-14 allows cashu tokens to be created with a preimage hash. However, nutshell (cashubtc/nuts) before 0.18.0 do not validate the size of preimage when the token is spent. The preimage is stored by the mint and attacker can exploit this vulnerability to fill the mint's db nd disk with arbitrary data.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2025-65548?

1 open source package ship an affected version, including cashu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cashu` | PyPI | All versions | 0.18.0 |

Products: Cashu Nutshell.

## How do I fix CVE-2025-65548?

Upgrade cashu to 0.18.0 or later.

## Is CVE-2025-65548 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65548 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65548 and fix it if it is affected.

What it is: CVE-2025-65548 is a critical denial of service vulnerability in n/a, published on 8 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65548 exists.

Affected packages and fixed versions:
- cashu (PyPI): affected all versions; fixed in 0.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65548/ (Markdown: https://insights.sbomify.com/CVE-2025-65548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65548
- OSV: https://osv.dev/vulnerability/CVE-2025-65548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65548/
Summaries are generated and may contain mistakes; the official description above is the record.
