# CVE-2025-65581: ABP Account Module has an Open Redirect through Improper validation in its register function

> Attackers can redirect users to malicious sites via the register function's returnUrl parameter in the ABP Framework.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2025
- **Updated:** 16 Dec 2025
- **Also known as:** GHSA-vfm5-cr22-jg3m

## What is CVE-2025-65581?

CVE-2025-65581 is a medium-severity vulnerability in n/a, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An open redirect vulnerability exists in the Account module in Volosoft ABP Framework >= 5.1.0 and < 10.0.0-rc.2. Improper validation of the returnUrl parameter in the register function allows an attacker to redirect users to arbitrary external domains.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-65581?

2 open source packages ship an affected version, including Volo.Abp.Account.Web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Volo.Abp.Account.Web` | NuGet | From 5.1.0 | 10.0.0-rc.2 |
| `Volo.Abp.Account.Web` | NuGet | From 5.1.0 | 10.0.0-rc.2 |

Products: Volosoft Abp.

## How do I fix CVE-2025-65581?

Upgrade Volo.Abp.Account.Web to 10.0.0-rc.2 or later.

## Is CVE-2025-65581 being exploited?

There is no known exploitation of CVE-2025-65581 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65581 and fix it if it is affected.

What it is: CVE-2025-65581 is a medium-severity vulnerability in n/a, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65581 in the wild and no public exploit code.

Affected packages and fixed versions:
- Volo.Abp.Account.Web (NuGet): affected from 5.1.0; fixed in 10.0.0-rc.2
- Volo.Abp.Account.Web (NuGet): affected from 5.1.0; fixed in 10.0.0-rc.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65581/ (Markdown: https://insights.sbomify.com/CVE-2025-65581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65581
- OSV: https://osv.dev/vulnerability/CVE-2025-65581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65581/
Summaries are generated and may contain mistakes; the official description above is the record.
