{"answers":{"affected":"2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65622 exists.","fix":"Upgrade snipe/snipe-it to 8.3.4 or later.","what":"CVE-2025-65622 is a medium-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 1 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-65622 and fix it if it is affected.\n\nWhat it is: CVE-2025-65622 is a medium-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 1 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65622 exists.\n\nAffected packages and fixed versions:\n- snipe/snipe-it (Packagist): affected all versions; fixed in 8.3.4\n- snipe/snipe-it (Packagist): affected all versions; fixed in 8.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65622/ (Markdown: https://insights.sbomify.com/CVE-2025-65622/index.md)","id":"CVE-2025-65622","markdown":"https://insights.sbomify.com/CVE-2025-65622/index.md","name":"CVE-2025-65622","record":{"aliases":["GHSA-4g25-wj72-chxg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Snipe-IT asset management","requires_auth":"low_privilege","summary":"Low-privileged users can inject JavaScript into the Locations Country field, executing code in other users' sessions to potentially steal data or take over accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"snipe-it","vendor":"snipeitapp"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Snipe-IT before 8.3.4 allows stored XSS via the Locations \"Country\" field, enabling a low-privileged authenticated user to inject JavaScript that executes in another user's session.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Snipe-IT allows stored XSS via the Locations \"Country\" field","id":"CVE-2025-65622","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"snipeitapp:snipe-it","products":["snipeitapp:snipe-it"],"type":"xss","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Logrus is vulnerable to DoS when using Entry.Writer()","id":"CVE-2025-65637"},"packages":[{"ecosystem":"Packagist","fixed":["8.3.4"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":null,"source":"GHSA-4g25-wj72-chxg"},{"ecosystem":"Packagist","fixed":["8.3.4"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":"pkg:composer/snipe/snipe-it","source":"GHSA-4g25-wj72-chxg"}],"prev":{"headline":"Snipe-IT is vulnerable to stored cross-site scripting","id":"CVE-2025-65621"},"products":["n/a"],"published":"2025-12-01","related":[{"cvss_score":9.9,"headline":"File upload in n/a","id":"CVE-2025-63601","kev_date_added":null,"published":"2025-11-05"},{"cvss_score":9.8,"headline":"Snipe-IT has insecure permissions in file uploads","id":"CVE-2026-37709","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":9.3,"headline":"Snipe-IT before 8.7.0 CSS Injection via Custom CSS","id":"CVE-2026-86738","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback","id":"CVE-2026-116199","kev_date_added":null,"published":"2026-10-25"},{"cvss_score":9.1,"headline":"Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it","id":"CVE-2022-1380","kev_date_added":null,"published":"2022-04-16"},{"cvss_score":9,"headline":"Stored Cross Site Scripting vulnerability in the checked_out_to parameter in snipe/snipe-it","id":"CVE-2022-1445","kev_date_added":null,"published":"2022-04-24"},{"cvss_score":8.8,"headline":"Snipe-IT - Host Header Injection","id":"CVE-2022-23064","kev_date_added":null,"published":"2022-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-05","vendors":["n/a"]},"summary":"Low-privileged users can inject JavaScript into the Locations Country field, executing code in other users' sessions to potentially steal data or take over accounts.","url":"https://insights.sbomify.com/CVE-2025-65622/"}