CVE-2025-65637 Logrus is vulnerable to DoS when using Entry.Writer()
An attacker can cause a denial of service in applications using the logrus library by sending large single-line payloads that break the writer pipe.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-65637?
CVE-2025-65637 is a high-severity denial of service vulnerability in n/a, published on 4 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A denial-of-service vulnerability exists in github.com/sirupsen/logrus when using Entry.Writer() to log a single-line payload larger than 64KB without newline characters. Due to limitations in the internal bufio.Scanner, the read fails with "token too long" and the writer pipe is closed, leaving Writer() unusable and causing application unavailability (DoS). This affects versions < 1.8.3, 1.9.0, and 1.9.2. The issue is fixed in 1.8.3, 1.9.1, and 1.9.3+, where the input is chunked and the writer continues to function even if an error is logged.
Weakness: CWE-400
Which versions are affected by CVE-2025-65637?
7 open source packages ship an affected version, including github.com/sirupsen/logrus. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/sirupsen/logrus Go | All versions | 1.8.3, 1.9.1, 1.9.3 |
github.com/sirupsen/logrus Go | All versions | 1.8.3 |
github.com/sirupsen/logrus Go | All versions | 1.8.3 |
github.com/sirupsen/logrus Go | From 1.9.0 | 1.9.1 |
github.com/sirupsen/logrus Go | From 1.9.0 | 1.9.1 |
github.com/sirupsen/logrus Go | From 1.9.2 | 1.9.3 |
1 more packages
github.com/sirupsen/logrus Go | From 1.9.2 | 1.9.3 |
Linux distribution packages (33)
openshift Red Hat:openshift:4.12::el8 | All versions | 0:4.12.0-202604271501.p2.gedc7ba9.assembly.stream.el8 |
openshift-hyperkube Red Hat:openshift:4.12::el8 | All versions | 0:4.12.0-202604271501.p2.gedc7ba9.assembly.stream.el8 |
openshift Red Hat:openshift:4.12::el9 | All versions | 0:4.12.0-202604271501.p2.gedc7ba9.assembly.stream.el9 |
openshift-hyperkube Red Hat:openshift:4.12::el9 | All versions | 0:4.12.0-202604271501.p2.gedc7ba9.assembly.stream.el9 |
openshift Red Hat:openshift:4.13::el8 | All versions | 0:4.13.0-202603240119.p2.g7aa9360.assembly.stream.el8 |
openshift-hyperkube Red Hat:openshift:4.13::el8 | All versions | 0:4.13.0-202603240119.p2.g7aa9360.assembly.stream.el8 |
openshift Red Hat:openshift:4.13::el9 | All versions | 0:4.13.0-202603240119.p2.g7aa9360.assembly.stream.el9 |
openshift-hyperkube Red Hat:openshift:4.13::el9 | All versions | 0:4.13.0-202603240119.p2.g7aa9360.assembly.stream.el9 |
openshift Red Hat:openshift:4.14::el8 | All versions | 0:4.14.0-202602170118.p2.ga3faddd.assembly.stream.el8 |
openshift-hyperkube Red Hat:openshift:4.14::el8 | All versions | 0:4.14.0-202602170118.p2.ga3faddd.assembly.stream.el8 |
openshift Red Hat:openshift:4.14::el9 | All versions | 0:4.14.0-202602170118.p2.ga3faddd.assembly.stream.el9 |
openshift-hyperkube Red Hat:openshift:4.14::el9 | All versions | 0:4.14.0-202602170118.p2.ga3faddd.assembly.stream.el9 |
openshift Red Hat:openshift:4.16::el8 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el8 |
openshift-hyperkube Red Hat:openshift:4.16::el8 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el8 |
openshift-kube-apiserver Red Hat:openshift:4.16::el8 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el8 |
openshift-kube-controller-manager Red Hat:openshift:4.16::el8 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el8 |
openshift-kube-scheduler Red Hat:openshift:4.16::el8 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el8 |
openshift-kubelet Red Hat:openshift:4.16::el8 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el8 |
microshift Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-greenboot Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-multus Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-multus-release-info Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-networking Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-olm Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-olm-release-info Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-release-info Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
microshift-selinux Red Hat:openshift:4.16::el9 | All versions | 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9 |
openshift Red Hat:openshift:4.16::el9 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el9 |
openshift-hyperkube Red Hat:openshift:4.16::el9 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el9 |
openshift-kube-apiserver Red Hat:openshift:4.16::el9 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el9 |
openshift-kube-controller-manager Red Hat:openshift:4.16::el9 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el9 |
openshift-kube-scheduler Red Hat:openshift:4.16::el9 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el9 |
openshift-kubelet Red Hat:openshift:4.16::el9 | All versions | 0:4.16.0-202602100409.p2.g41c4e9b.assembly.stream.el9 |
Products include Turbopuffer Logrus.
How do I fix CVE-2025-65637?
Upgrade github.com/sirupsen/logrus to a fixed version for your release line: 1.8.3, 1.9.1 or 1.9.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-65637 being exploited?
There is no known exploitation of CVE-2025-65637 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as AZL-71452, AZL-71473, AZL-71476, AZL-71479, AZL-71482, AZL-71500 and 67 more.