{"answers":{"affected":"3 open source packages ship an affected version, including homeassistant. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65713 exists.","fix":"Upgrade homeassistant to 2025.8.0 or later.","what":"CVE-2025-65713 is a medium-severity path traversal vulnerability in n/a, published on 23 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-65713 and fix it if it is affected.\n\nWhat it is: CVE-2025-65713 is a medium-severity path traversal vulnerability in n/a, published on 23 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65713 exists.\n\nAffected packages and fixed versions:\n- homeassistant (PyPI): affected all versions; fixed in 2025.8.0\n- homeassistant (PyPI): affected all versions; fixed in 2025.8.0\n- homeassistant (PyPI): affected all versions; fixed in 2025.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65713/ (Markdown: https://insights.sbomify.com/CVE-2025-65713/index.md)","id":"CVE-2025-65713","markdown":"https://insights.sbomify.com/CVE-2025-65713/index.md","name":"CVE-2025-65713","record":{"aliases":["GHSA-pp3g-xmm4-5cw9","PYSEC-2026-1454"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Home Assistant Core","requires_auth":"none","summary":"Attackers can exploit a path traversal flaw in the Downloader integration to read or modify arbitrary files on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"home-assistant","vendor":"home-assistant"}],"cvss":{"score":4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Home Assistant Core before is vulnerable to Directory Traversal","id":"CVE-2025-65713","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Code injection in n/a","id":"CVE-2025-65715"},"packages":[{"ecosystem":"PyPI","fixed":["2025.8.0"],"introduced":["0"],"last_affected":[],"package":"homeassistant","purl":null,"source":"GHSA-pp3g-xmm4-5cw9"},{"ecosystem":"PyPI","fixed":["2025.8.0"],"introduced":["0"],"last_affected":[],"package":"homeassistant","purl":"pkg:pypi/homeassistant","source":"GHSA-pp3g-xmm4-5cw9"},{"ecosystem":"PyPI","fixed":["2025.8.0"],"introduced":["0"],"last_affected":[],"package":"homeassistant","purl":"pkg:pypi/homeassistant","source":"PYSEC-2026-1454"}],"prev":{"headline":"Overhang Tutor Discloses Sensitive Information due to Improper Cache-Control","id":"CVE-2025-65681"},"products":["n/a"],"published":"2025-12-23","related":[{"cvss_score":10,"headline":"Auth bypass in core","id":"CVE-2023-27482","kev_date_added":null,"published":"2023-03-08"},{"cvss_score":8.8,"headline":"Cross-site Scripting via auth_callback login in Home Assistant Core","id":"CVE-2023-41895","kev_date_added":null,"published":"2023-10-19"},{"cvss_score":8.8,"headline":"Lack of XFO header allows clickjacking in Home Assistant Core","id":"CVE-2023-41897","kev_date_added":null,"published":"2023-10-19"},{"cvss_score":7.6,"headline":"Home Assistant: Konnected alarm-panel switch state and zone topology disclosed to unauthenticated actors on the LAN","id":"CVE-2026-54317","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2020-36517","kev_date_added":null,"published":"2022-03-07"},{"cvss_score":7.5,"headline":"Home Assistant information disclosure vulnerability","id":"CVE-2018-21019","kev_date_added":null,"published":"2019-09-23"},{"cvss_score":7.3,"headline":"Home Assistant has stored XSS in Map-card through malicious device name","id":"CVE-2026-33044","kev_date_added":null,"published":"2026-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-23","vendors":["n/a"]},"summary":"Attackers can exploit a path traversal flaw in the Downloader integration to read or modify arbitrary files on the server.","url":"https://insights.sbomify.com/CVE-2025-65713/"}