# CVE-2025-65713: Home Assistant Core before is vulnerable to Directory Traversal

> Attackers can exploit a path traversal flaw in the Downloader integration to read or modify arbitrary files on the server.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2025
- **Updated:** 23 Dec 2025
- **Also known as:** GHSA-pp3g-xmm4-5cw9, PYSEC-2026-1454

## What is CVE-2025-65713?

CVE-2025-65713 is a medium-severity path traversal vulnerability in n/a, published on 23 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-65713?

3 open source packages ship an affected version, including homeassistant. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `homeassistant` | PyPI | All versions | 2025.8.0 |
| `homeassistant` | PyPI | All versions | 2025.8.0 |
| `homeassistant` | PyPI | All versions | 2025.8.0 |

Products: Home-Assistant Home-Assistant.

## How do I fix CVE-2025-65713?

Upgrade homeassistant to 2025.8.0 or later.

## Is CVE-2025-65713 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65713 exists.

## Other vulnerabilities in n/a

- [CVE-2023-27482](https://insights.sbomify.com/CVE-2023-27482/): Auth bypass in core (critical 10.0)
- [CVE-2023-41895](https://insights.sbomify.com/CVE-2023-41895/): Cross-site Scripting via auth_callback login in Home Assistant Core (high 8.8)
- [CVE-2023-41897](https://insights.sbomify.com/CVE-2023-41897/): Lack of XFO header allows clickjacking in Home Assistant Core (high 8.8)
- [CVE-2026-54317](https://insights.sbomify.com/CVE-2026-54317/): Home Assistant: Konnected alarm-panel switch state and zone topology disclosed to unauthenticated actors on the LAN (high 7.6)
- [CVE-2020-36517](https://insights.sbomify.com/CVE-2020-36517/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65713 and fix it if it is affected.

What it is: CVE-2025-65713 is a medium-severity path traversal vulnerability in n/a, published on 23 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65713 exists.

Affected packages and fixed versions:
- homeassistant (PyPI): affected all versions; fixed in 2025.8.0
- homeassistant (PyPI): affected all versions; fixed in 2025.8.0
- homeassistant (PyPI): affected all versions; fixed in 2025.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65713/ (Markdown: https://insights.sbomify.com/CVE-2025-65713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65713
- OSV: https://osv.dev/vulnerability/CVE-2025-65713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65713/
Summaries are generated and may contain mistakes; the official description above is the record.
