{"answers":{"affected":"3 open source packages ship an affected version, including gpt-researcher.","exploited":"There is no known exploitation of CVE-2025-65720 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-65720 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-65720 is a critical command injection vulnerability in n/a, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-65720 and fix it if it is affected.\n\nWhat it is: CVE-2025-65720 is a critical command injection vulnerability in n/a, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-65720 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gpt-researcher (PyPI): affected from 0.14.5 up to 0.14.7; no fix listed\n- gpt-researcher (PyPI): affected from 0.14.5 up to 0.14.7; no fix listed\n- gpt-researcher (PyPI): affected from 0.14.5 up to 0.14.7; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65720/ (Markdown: https://insights.sbomify.com/CVE-2025-65720/index.md)","id":"CVE-2025-65720","markdown":"https://insights.sbomify.com/CVE-2025-65720/index.md","name":"CVE-2025-65720","record":{"aliases":["GHSA-8j86-h8gg-797p","PYSEC-2026-4219"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python research library","requires_auth":"none","summary":"Attackers can execute arbitrary commands on victim systems via user interaction with a crafted HTML page in GPT Researcher.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"An issue in Open Source GPT Researcher v3.3.7 allows attackers to execute arbitrary commands on a victim system via user interaction with a crafted HTML page.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"GPT Researcher MCP STDIO configuration allows remote command execution","id":"CVE-2025-65720","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2025-65730"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0.14.5"],"last_affected":["0.14.7"],"package":"gpt-researcher","purl":null,"source":"GHSA-8j86-h8gg-797p"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.14.5"],"last_affected":["0.14.7"],"package":"gpt-researcher","purl":"pkg:pypi/gpt-researcher","source":"GHSA-8j86-h8gg-797p"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.14.5"],"last_affected":["0.14.7"],"package":"gpt-researcher","purl":"pkg:pypi/gpt-researcher","source":"PYSEC-2026-4219"}],"prev":{"headline":"Open Source Kubectl MCP Server vulnerable to arbitrary code execution via user interaction with crafted HTML page","id":"CVE-2025-65719"},"products":["n/a"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands on victim systems via user interaction with a crafted HTML page in GPT Researcher.","url":"https://insights.sbomify.com/CVE-2025-65720/"}