# CVE-2025-65730: Hardcoded credentials in n/a

> Attackers can bypass authentication and take over accounts by exploiting hardcoded JWT signing secrets in the GoAway library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Dec 2025
- **Updated:** 8 Dec 2025
- **Also known as:** GHSA-6xgv-g9h7-chvc

## What is CVE-2025-65730?

CVE-2025-65730 is a high-severity vulnerability in n/a, published on 5 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Authentication Bypass via Hardcoded Credentials GoAway up to v0.62.18, fixed in 0.62.19, uses a hardcoded secret for signing JWT tokens used for authentication.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2025-65730?

It affects 1 product.


Products: Pommee Goaway.

## How do I fix CVE-2025-65730?

No fix has been published for CVE-2025-65730 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65730 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65730 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65730 and fix it if it is affected.

What it is: CVE-2025-65730 is a high-severity vulnerability in n/a, published on 5 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65730 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65730/ (Markdown: https://insights.sbomify.com/CVE-2025-65730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65730
- OSV: https://osv.dev/vulnerability/CVE-2025-65730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65730/
Summaries are generated and may contain mistakes; the official description above is the record.
