{"answers":{"affected":"7 open source packages ship an affected version, including github.com/VictoriaMetrics/VictoriaMetrics.","exploited":"There is no known exploitation of CVE-2025-65942 in the wild and no public exploit code.","fix":"Upgrade github.com/VictoriaMetrics/VictoriaMetrics to a fixed version for your release line: 1.110.23, 1.122.8 or 1.129.1.","what":"CVE-2025-65942 is a low-severity denial of service vulnerability in VictoriaMetrics, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-65942 and fix it if it is affected.\n\nWhat it is: CVE-2025-65942 is a low-severity denial of service vulnerability in VictoriaMetrics, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-65942 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected all versions; fixed in 1.110.23, 1.122.8, 1.129.1\n- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.0.0; fixed in 1.110.23\n- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.0.0; fixed in 1.110.23\n- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.111.0; fixed in 1.122.8\n- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.111.0; fixed in 1.122.8\n- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.123.0; fixed in 1.129.1\n- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.123.0; fixed in 1.129.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65942/ (Markdown: https://insights.sbomify.com/CVE-2025-65942/index.md)","id":"CVE-2025-65942","markdown":"https://insights.sbomify.com/CVE-2025-65942/index.md","name":"CVE-2025-65942","record":{"aliases":["CLEANSTART-2026-QK91843","GHSA-66jq-2c23-2xh5","GO-2025-4161","MINI-474w-2gpx-vh35","MINI-6rqq-344m-h58p","MINI-964w-cm2j-2wpj","MINI-mj8f-hm56-f5r5","MINI-w4m8-r4pw-g2f8","MINI-wm27-7f7w-3x8q"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Time series database","requires_auth":"high_privilege","summary":"Attackers can cause denial of service via OOM errors by sending malformed blocks that bypass size limits in VictoriaMetrics.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"VictoriaMetrics is a scalable solution for monitoring and managing time series data. In versions from 1.0.0 to before 1.110.23, from 1.111.0 to before 1.122.8, and from 1.123.0 to before 1.129.1, affected versions are vulnerable to DoS attacks because the snappy decoder ignored VictoriaMetrics request size limits allowing malformed blocks to trigger excessive memory use. This could lead to OOM errors and service instability. The fix enforces block-size checks based on MaxRequest limits. This issue has been patched in versions 1.110.23, 1.122.8, and 1.129.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"VictoriaMetrics Snappy Decoder DoS Vulnerability is Causing OOM","id":"CVE-2025-65942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":7,"n_references":5,"next":{"headline":"Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`","id":"CVE-2025-65944"},"packages":[{"ecosystem":"Go","fixed":["1.110.23","1.122.8","1.129.1"],"introduced":["0","1.111.0","1.123.0"],"last_affected":[],"package":"github.com/VictoriaMetrics/VictoriaMetrics","purl":"pkg:golang/github.com/VictoriaMetrics/VictoriaMetrics","source":"GO-2025-4161"},{"ecosystem":"Go","fixed":["1.110.23"],"introduced":["1.0.0"],"last_affected":[],"package":"github.com/VictoriaMetrics/VictoriaMetrics","purl":null,"source":"GHSA-66jq-2c23-2xh5"},{"ecosystem":"Go","fixed":["1.110.23"],"introduced":["1.0.0"],"last_affected":[],"package":"github.com/VictoriaMetrics/VictoriaMetrics","purl":"pkg:golang/github.com/VictoriaMetrics/VictoriaMetrics","source":"GHSA-66jq-2c23-2xh5"},{"ecosystem":"Go","fixed":["1.122.8"],"introduced":["1.111.0"],"last_affected":[],"package":"github.com/VictoriaMetrics/VictoriaMetrics","purl":null,"source":"GHSA-66jq-2c23-2xh5"},{"ecosystem":"Go","fixed":["1.122.8"],"introduced":["1.111.0"],"last_affected":[],"package":"github.com/VictoriaMetrics/VictoriaMetrics","purl":"pkg:golang/github.com/VictoriaMetrics/VictoriaMetrics","source":"GHSA-66jq-2c23-2xh5"},{"ecosystem":"Go","fixed":["1.129.1"],"introduced":["1.123.0"],"last_affected":[],"package":"github.com/VictoriaMetrics/VictoriaMetrics","purl":null,"source":"GHSA-66jq-2c23-2xh5"},{"ecosystem":"Go","fixed":["1.129.1"],"introduced":["1.123.0"],"last_affected":[],"package":"github.com/VictoriaMetrics/VictoriaMetrics","purl":"pkg:golang/github.com/VictoriaMetrics/VictoriaMetrics","source":"GHSA-66jq-2c23-2xh5"}],"prev":{"headline":"Not used","id":"CVE-2025-65941"},"products":["VictoriaMetrics"],"published":"2025-11-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-26","vendors":["VictoriaMetrics"]},"summary":"Attackers can cause denial of service via OOM errors by sending malformed blocks that bypass size limits in VictoriaMetrics.","url":"https://insights.sbomify.com/CVE-2025-65942/"}