# CVE-2025-65942: VictoriaMetrics Snappy Decoder DoS Vulnerability is Causing OOM

> Attackers can cause denial of service via OOM errors by sending malformed blocks that bypass size limits in VictoriaMetrics.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 26 Nov 2025
- **Also known as:** CLEANSTART-2026-QK91843, GHSA-66jq-2c23-2xh5, GO-2025-4161, MINI-474w-2gpx-vh35, MINI-6rqq-344m-h58p, MINI-964w-cm2j-2wpj, MINI-mj8f-hm56-f5r5, MINI-w4m8-r4pw-g2f8, MINI-wm27-7f7w-3x8q

## What is CVE-2025-65942?

CVE-2025-65942 is a low-severity denial of service vulnerability in VictoriaMetrics, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

VictoriaMetrics is a scalable solution for monitoring and managing time series data. In versions from 1.0.0 to before 1.110.23, from 1.111.0 to before 1.122.8, and from 1.123.0 to before 1.129.1, affected versions are vulnerable to DoS attacks because the snappy decoder ignored VictoriaMetrics request size limits allowing malformed blocks to trigger excessive memory use. This could lead to OOM errors and service instability. The fix enforces block-size checks based on MaxRequest limits. This issue has been patched in versions 1.110.23, 1.122.8, and 1.129.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-65942?

7 open source packages ship an affected version, including github.com/VictoriaMetrics/VictoriaMetrics.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | All versions | 1.110.23, 1.122.8, 1.129.1 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.0.0 | 1.110.23 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.0.0 | 1.110.23 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.111.0 | 1.122.8 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.111.0 | 1.122.8 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.123.0 | 1.129.1 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.123.0 | 1.129.1 |

## How do I fix CVE-2025-65942?

Upgrade github.com/VictoriaMetrics/VictoriaMetrics to a fixed version for your release line: 1.110.23, 1.122.8 or 1.129.1.

## Is CVE-2025-65942 being exploited?

There is no known exploitation of CVE-2025-65942 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65942 and fix it if it is affected.

What it is: CVE-2025-65942 is a low-severity denial of service vulnerability in VictoriaMetrics, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65942 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected all versions; fixed in 1.110.23, 1.122.8, 1.129.1
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.0.0; fixed in 1.110.23
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.0.0; fixed in 1.110.23
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.111.0; fixed in 1.122.8
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.111.0; fixed in 1.122.8
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.123.0; fixed in 1.129.1
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.123.0; fixed in 1.129.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65942/ (Markdown: https://insights.sbomify.com/CVE-2025-65942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65942
- OSV: https://osv.dev/vulnerability/CVE-2025-65942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65942/
Summaries are generated and may contain mistakes; the official description above is the record.
