CVE-2025-65944 Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`

Medium 5.1 Published Updated

Developers using Sentry-JavaScript with PII enabled may leak sensitive headers, allowing attackers to impersonate users or escalate privileges.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-65944?

CVE-2025-65944 is a medium-severity vulnerability in getsentry sentry-javascript, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

Weakness: CWE-201

Which versions are affected by CVE-2025-65944?

24 open source packages ship an affected version, including @sentry/astro, @sentry/aws-serverless and @sentry/bun.

PackageAffectedFixed in
@sentry/astro npmFrom 10.11.010.27.0
@sentry/astro npmFrom 10.11.010.27.0
@sentry/aws-serverless npmFrom 10.11.010.27.0
@sentry/aws-serverless npmFrom 10.11.010.27.0
@sentry/bun npmFrom 10.11.010.27.0
@sentry/bun npmFrom 10.11.010.27.0
18 more packages
@sentry/google-cloud-serverless npmFrom 10.11.010.27.0
@sentry/google-cloud-serverless npmFrom 10.11.010.27.0
@sentry/nestjs npmFrom 10.11.010.27.0
@sentry/nestjs npmFrom 10.11.010.27.0
@sentry/nextjs npmFrom 10.11.010.27.0
@sentry/nextjs npmFrom 10.11.010.27.0
@sentry/node npmFrom 10.11.010.27.0
@sentry/node npmFrom 10.11.010.27.0
@sentry/node-core npmFrom 10.11.010.27.0
@sentry/node-core npmFrom 10.11.010.27.0
@sentry/nuxt npmFrom 10.11.010.27.0
@sentry/nuxt npmFrom 10.11.010.27.0
@sentry/remix npmFrom 10.11.010.27.0
@sentry/remix npmFrom 10.11.010.27.0
@sentry/solidstart npmFrom 10.11.010.27.0
@sentry/solidstart npmFrom 10.11.010.27.0
@sentry/sveltekit npmFrom 10.11.010.27.0
@sentry/sveltekit npmFrom 10.11.010.27.0

How do I fix CVE-2025-65944?

Upgrade @sentry/astro to 10.27.0 or later.

Is CVE-2025-65944 being exploited?

There is no known exploitation of CVE-2025-65944 in the wild and no public exploit code.

Sources

Also known as GHSA-6465-jgvq-jhgp.

Is CVE-2025-65944 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free