CVE-2025-65950 WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter

Critical 9.4 Published Updated

A low-privileged authenticated user can execute arbitrary SQL queries via the groups[] parameter, leading to database compromise and data exfiltration.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-65950?

CVE-2025-65950 is a critical SQL injection vulnerability in WBCE_CMS, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

WBCE CMS is a content management system. In versions 1.6.4 and below, the user management module allows a low-privileged authenticated user with permissions to modify users to execute arbitrary SQL queries. This can be escalated to a full database compromise, data exfiltration, effectively bypassing all security controls. The vulnerability exists in the admin/users/save.php script, which handles updates to user profiles. The script improperly processes the groups[] parameter sent from the user edit form. This issue is fixed in version 1.6.5.

Weakness: CWE-89

Which versions are affected by CVE-2025-65950?

It affects 1 product.

Products include Wbce Wbce Cms.

How do I fix CVE-2025-65950?

No fix has been published for CVE-2025-65950 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-65950 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65950 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-934v-xhx9-j2f3.

Is CVE-2025-65950 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free