# CVE-2025-65952: Console is vulnerable to path traversal regarding custom assets

> Attackers can exploit path traversal in the Gorilla Tag mod console to write files to arbitrary directories outside the intended path.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Nov 2025
- **Updated:** 26 Nov 2025
- **Also known as:** GHSA-c3f7-xh45-2xc7

## What is CVE-2025-65952?

CVE-2025-65952 is a high-severity path traversal vulnerability in iiDk-the-actual Console, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Console is a network used to control Gorilla Tag mods' users and other users on the network. Prior to version 2.8.0, a path traversal vulnerability exists where complicated combinations of backslashes and periods can be used to escape the Gorilla Tag path and write to unwanted directories. This issue has been patched in version 2.8.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-65952?


## How do I fix CVE-2025-65952?

No fix has been published for CVE-2025-65952 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65952 being exploited?

There is no known exploitation of CVE-2025-65952 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65952 and fix it if it is affected.

What it is: CVE-2025-65952 is a high-severity path traversal vulnerability in iiDk-the-actual Console, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65952 in the wild and no public exploit code.

Affected product: iiDk-the-actual Console. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65952/ (Markdown: https://insights.sbomify.com/CVE-2025-65952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65952
- OSV: https://osv.dev/vulnerability/CVE-2025-65952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65952/
Summaries are generated and may contain mistakes; the official description above is the record.
