CVE-2025-65954 SimpleSAMLphp-casserver has an Open Redirect vulnerability via logout
Attackers can redirect users to malicious sites via the logout endpoint in SimpleSAMLphp-casserver, requiring specific logout configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-65954?
CVE-2025-65954 is a medium-severity vulnerability in simplesamlphp-module-casserver, published on 18 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
SimpleSAMLphp-casserver is a CAS 1.0 and 2.0 compliant CAS server in the form of a SimpleSAMLphp module. In versions below 6.3.1 and 7.0.0, the logout endpoint accepts a url query parameter to redirect to. casserver treats that url as trusted, and either (depending on configuration) redirects the browser there, or shows a "you've been logged out" page with a link to continue to that url. Impacted configs include 'enable_logout' => true, and 'skip_logout_page' -> true. This issue has been resolved in versions 6.3.1 and 7.0.0.
Weakness: CWE-601
Which versions are affected by CVE-2025-65954?
4 open source packages ship an affected version, including simplesamlphp/simplesamlphp-module-casserver. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
simplesamlphp/simplesamlphp-module-casserver Packagist | All versions | 6.3.1 |
simplesamlphp/simplesamlphp-module-casserver Packagist | All versions | 6.3.1 |
simplesamlphp/simplesamlphp-module-casserver Packagist | From 7.0.0-rc1 | 7.0.0 |
simplesamlphp/simplesamlphp-module-casserver Packagist | From 7.0.0-rc1 | 7.0.0 |
Products include Simplesamlphp Simplesamlphp-Module-Casserver.
How do I fix CVE-2025-65954?
Upgrade simplesamlphp/simplesamlphp-module-casserver to a fixed version for your release line: 6.3.1 or 7.0.0.
Is CVE-2025-65954 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65954 exists.
Sources
Also known as GHSA-cvrm-5hp6-h523.