# CVE-2025-65954: SimpleSAMLphp-casserver has an Open Redirect vulnerability via logout

> Attackers can redirect users to malicious sites via the logout endpoint in SimpleSAMLphp-casserver, requiring specific logout configurations.

- **Severity:** Medium 4.7 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-cvrm-5hp6-h523

## What is CVE-2025-65954?

CVE-2025-65954 is a medium-severity vulnerability in simplesamlphp-module-casserver, published on 18 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SimpleSAMLphp-casserver is a CAS 1.0 and 2.0 compliant CAS server in the form of a SimpleSAMLphp module. In versions below 6.3.1 and 7.0.0, the logout endpoint accepts a url query parameter to redirect to. casserver treats that url as trusted, and either (depending on configuration) redirects the browser there, or shows a "you've been logged out" page with a link to continue to that url. Impacted configs include 'enable_logout' => true, and 'skip_logout_page' -> true. This issue has been resolved in versions 6.3.1 and 7.0.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-65954?

4 open source packages ship an affected version, including simplesamlphp/simplesamlphp-module-casserver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp-module-casserver` | Packagist | All versions | 6.3.1 |
| `simplesamlphp/simplesamlphp-module-casserver` | Packagist | All versions | 6.3.1 |
| `simplesamlphp/simplesamlphp-module-casserver` | Packagist | From 7.0.0-rc1 | 7.0.0 |
| `simplesamlphp/simplesamlphp-module-casserver` | Packagist | From 7.0.0-rc1 | 7.0.0 |

Products: Simplesamlphp Simplesamlphp-Module-Casserver.

## How do I fix CVE-2025-65954?

Upgrade simplesamlphp/simplesamlphp-module-casserver to a fixed version for your release line: 6.3.1 or 7.0.0.

## Is CVE-2025-65954 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65954 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65954 and fix it if it is affected.

What it is: CVE-2025-65954 is a medium-severity vulnerability in simplesamlphp-module-casserver, published on 18 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65954 exists.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp-module-casserver (Packagist): affected all versions; fixed in 6.3.1
- simplesamlphp/simplesamlphp-module-casserver (Packagist): affected all versions; fixed in 6.3.1
- simplesamlphp/simplesamlphp-module-casserver (Packagist): affected from 7.0.0-rc1; fixed in 7.0.0
- simplesamlphp/simplesamlphp-module-casserver (Packagist): affected from 7.0.0-rc1; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65954/ (Markdown: https://insights.sbomify.com/CVE-2025-65954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65954
- OSV: https://osv.dev/vulnerability/CVE-2025-65954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65954/
Summaries are generated and may contain mistakes; the official description above is the record.
