# CVE-2025-65956: Formwork CMS Has a Stored Cross-Site Scripting (XSS) Vulnerability in Blog Tags

> Attackers can inject malicious scripts via blog tags, leading to code execution in the browsers of authenticated users, including administrators.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 26 Nov 2025
- **Also known as:** GHSA-7j46-f57w-76pj

## What is CVE-2025-65956?

CVE-2025-65956 is a medium-severity cross-site scripting vulnerability in getformwork formwork, published on 25 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Formwork is a flat file-based Content Management System (CMS). Prior to version 2.2.0, inserting unsanitized data into the blog tag field results in stored cross‑site scripting (XSS). Any user with credentials to the Formwork CMS who accesses or edits an affected blog post will have attacker‑controlled script executed in their browser. The issue is persistent and impacts privileged administrative workflows. This issue has been patched in version 2.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65956?

2 open source packages ship an affected version, including getformwork/formwork. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getformwork/formwork` | Packagist | All versions | 2.2.0 |
| `getformwork/formwork` | Packagist | All versions | 2.2.0 |

Products: Formwork Project Formwork.

## How do I fix CVE-2025-65956?

Upgrade getformwork/formwork to 2.2.0 or later.

## Is CVE-2025-65956 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65956 exists.

## Other vulnerabilities in getformwork formwork

- [CVE-2026-27198](https://insights.sbomify.com/CVE-2026-27198/): Formwork Improperly Manages Privileges During User Creation (high 8.8)
- [CVE-2024-37160](https://insights.sbomify.com/CVE-2024-37160/): Formwork has a Cross-site scripting (XSS) vulnerability in Description metadata (medium 4.8)
- [CVE-2023-24230](https://insights.sbomify.com/CVE-2023-24230/): Formwork Cross-site Scripting (XSS) from Page title field (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65956 and fix it if it is affected.

What it is: CVE-2025-65956 is a medium-severity cross-site scripting vulnerability in getformwork formwork, published on 25 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65956 exists.

Affected packages and fixed versions:
- getformwork/formwork (Packagist): affected all versions; fixed in 2.2.0
- getformwork/formwork (Packagist): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65956/ (Markdown: https://insights.sbomify.com/CVE-2025-65956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65956
- OSV: https://osv.dev/vulnerability/CVE-2025-65956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65956/
Summaries are generated and may contain mistakes; the official description above is the record.
