{"answers":{"affected":"3 open source packages ship an affected version, including open-webui. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65958 exists.","fix":"Upgrade open-webui to 0.6.37 or later.","what":"CVE-2025-65958 is a high-severity server-side request forgery vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-65958 and fix it if it is affected.\n\nWhat it is: CVE-2025-65958 is a high-severity server-side request forgery vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65958 exists.\n\nAffected packages and fixed versions:\n- open-webui (PyPI): affected all versions; fixed in 0.6.37\n- open-webui (PyPI): affected all versions; fixed in 0.6.37\n- open-webui (PyPI): affected all versions; fixed in 0.6.37\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65958/ (Markdown: https://insights.sbomify.com/CVE-2025-65958/index.md)","id":"CVE-2025-65958","markdown":"https://insights.sbomify.com/CVE-2025-65958/index.md","name":"CVE-2025-65958","record":{"aliases":["GHSA-c6xv-rcvw-v685","PYSEC-2026-1726"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AI platform","requires_auth":"low_privilege","summary":"Authenticated users can force the server to make arbitrary HTTP requests, enabling access to internal networks and cloud metadata.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"open_webui","vendor":"openwebui"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.6.37, a Server-Side Request Forgery (SSRF) vulnerability in Open WebUI allows any authenticated user to force the server to make HTTP requests to arbitrary URLs. This can be exploited to access cloud metadata endpoints (AWS/GCP/Azure), scan internal networks, access internal services behind firewalls, and exfiltrate sensitive information. No special permissions beyond basic authentication are required. This vulnerability is fixed in 0.6.37.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Open WebUI vulnerable to Server-Side Request Forgery (SSRF) via Arbitrary URL Processing in /api/v1/retrieval/process/web","id":"CVE-2025-65958","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"openwebui:open_webui","products":["openwebui:open_webui"],"type":"ssrf","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Open WebUI vulnerable to Stored DOM XSS via Note 'Download PDF'","id":"CVE-2025-65959"},"packages":[{"ecosystem":"PyPI","fixed":["0.6.37"],"introduced":["0"],"last_affected":[],"package":"open-webui","purl":null,"source":"GHSA-c6xv-rcvw-v685"},{"ecosystem":"PyPI","fixed":["0.6.37"],"introduced":["0"],"last_affected":[],"package":"open-webui","purl":"pkg:pypi/open-webui","source":"GHSA-c6xv-rcvw-v685"},{"ecosystem":"PyPI","fixed":["0.6.37"],"introduced":["0"],"last_affected":[],"package":"open-webui","purl":"pkg:pypi/open-webui","source":"PYSEC-2026-1726"}],"prev":{"headline":"Core Bot is Leaking Sensitive Credentials in Logs, Errors, and Messages","id":"CVE-2025-65957"},"products":["open-webui"],"published":"2025-12-04","related":[{"cvss_score":9.1,"headline":"Open WebUI: LDAP Empty Password Authentication Bypass","id":"CVE-2026-44551","kev_date_added":null,"published":"2026-05-15"},{"cvss_score":9,"headline":"open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation","id":"CVE-2026-56400","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":9,"headline":"Cross-site Scripting (XSS) in open-webui/open-webui","id":"CVE-2024-8017","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":8.8,"headline":"Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed","id":"CVE-2026-45672","kev_date_added":null,"published":"2026-05-15"},{"cvss_score":8.7,"headline":"Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin","id":"CVE-2026-87995","kev_date_added":null,"published":"2026-09-09"},{"cvss_score":8.7,"headline":"Open WebUI: Stored XSS via unescaped KaTeX render-error fallback in rendered messages","id":"CVE-2026-70492","kev_date_added":null,"published":"2026-08-04"},{"cvss_score":8.7,"headline":"Open WebUI: Stored XSS in Mermaid Markdown Preview","id":"CVE-2026-54011","kev_date_added":null,"published":"2026-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-08","vendors":["open-webui"]},"summary":"Authenticated users can force the server to make arbitrary HTTP requests, enabling access to internal networks and cloud metadata.","url":"https://insights.sbomify.com/CVE-2025-65958/"}