# CVE-2025-65958: Open WebUI vulnerable to Server-Side Request Forgery (SSRF) via Arbitrary URL Processing in /api/v1/retrieval/process/web

> Authenticated users can force the server to make arbitrary HTTP requests, enabling access to internal networks and cloud metadata.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2025
- **Updated:** 8 Dec 2025
- **Also known as:** GHSA-c6xv-rcvw-v685, PYSEC-2026-1726

## What is CVE-2025-65958?

CVE-2025-65958 is a high-severity server-side request forgery vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.6.37, a Server-Side Request Forgery (SSRF) vulnerability in Open WebUI allows any authenticated user to force the server to make HTTP requests to arbitrary URLs. This can be exploited to access cloud metadata endpoints (AWS/GCP/Azure), scan internal networks, access internal services behind firewalls, and exfiltrate sensitive information. No special permissions beyond basic authentication are required. This vulnerability is fixed in 0.6.37.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-65958?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.6.37 |
| `open-webui` | PyPI | All versions | 0.6.37 |
| `open-webui` | PyPI | All versions | 0.6.37 |

Products: Openwebui Open Webui.

## How do I fix CVE-2025-65958?

Upgrade open-webui to 0.6.37 or later.

## Is CVE-2025-65958 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65958 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65958 and fix it if it is affected.

What it is: CVE-2025-65958 is a high-severity server-side request forgery vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65958 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.6.37
- open-webui (PyPI): affected all versions; fixed in 0.6.37
- open-webui (PyPI): affected all versions; fixed in 0.6.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65958/ (Markdown: https://insights.sbomify.com/CVE-2025-65958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65958
- OSV: https://osv.dev/vulnerability/CVE-2025-65958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65958/
Summaries are generated and may contain mistakes; the official description above is the record.
