# CVE-2025-65959: Open WebUI vulnerable to Stored DOM XSS via Note 'Download PDF'

> Attackers can execute arbitrary JavaScript and steal session tokens by injecting malicious SVG tags into Notes via Markdown imports.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-8wvc-869r-xfqf

## What is CVE-2025-65959?

CVE-2025-65959 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.6.37, a Stored XSS vulnerability was discovered in Open-WebUI's Notes PDF download functionality. An attacker can import a Markdown file containing malicious SVG tags into Notes, allowing them to execute arbitrary JavaScript code and steal session tokens when a victim downloads the note as PDF. This vulnerability can be exploited by any authenticated user, and unauthenticated external attackers can steal session tokens from users (both admin and regular users) by sharing specially crafted markdown files. This vulnerability is fixed in 0.6.37.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65959?

2 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | npm | All versions | 0.6.37 |
| `open-webui` | npm | All versions | 0.6.37 |

Products: Openwebui Open Webui.

## How do I fix CVE-2025-65959?

Upgrade open-webui to 0.6.37 or later.

## Is CVE-2025-65959 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65959 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65959 and fix it if it is affected.

What it is: CVE-2025-65959 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65959 exists.

Affected packages and fixed versions:
- open-webui (npm): affected all versions; fixed in 0.6.37
- open-webui (npm): affected all versions; fixed in 0.6.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65959/ (Markdown: https://insights.sbomify.com/CVE-2025-65959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65959
- OSV: https://osv.dev/vulnerability/CVE-2025-65959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65959/
Summaries are generated and may contain mistakes; the official description above is the record.
