CVE-2025-65960 Contao is vulnerable to remote code execution in template closures
Back end users with template closure control can execute arbitrary PHP functions, leading to remote code execution in Contao CMS.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-65960?
CVE-2025-65960 is a medium-severity code injection vulnerability in contao, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, back end users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves manually patching the Contao\Template::once() method.
Weakness: CWE-351
Which versions are affected by CVE-2025-65960?
6 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/core-bundle Packagist | From 4.0.0 | 4.13.57 |
contao/core-bundle Packagist | From 4.0.0 | 4.13.57 |
contao/core-bundle Packagist | From 5.0.0-RC1 | 5.3.42 |
contao/core-bundle Packagist | From 5.0.0-RC1 | 5.3.42 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.5 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.5 |
Products include Contao Contao.
How do I fix CVE-2025-65960?
Upgrade contao/core-bundle to a fixed version for your release line: 4.13.57, 5.3.42 or 5.6.5.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-65960 being exploited?
There is no known exploitation of CVE-2025-65960 in the wild and no public exploit code.
Other vulnerabilities in contao
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-98vj-mm79-v77r.