CVE-2025-65961 Contao is vulnerable to cross-site scripting in templates
Attackers can inject malicious scripts into Contao templates, leading to code execution in user browsers.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-65961?
CVE-2025-65961 is a low-severity cross-site scripting vulnerability in contao, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
Which versions are affected by CVE-2025-65961?
6 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/core-bundle Packagist | From 4.0.0 | 4.13.57 |
contao/core-bundle Packagist | From 4.0.0 | 4.13.57 |
contao/core-bundle Packagist | From 5.0.0-RC1 | 5.3.42 |
contao/core-bundle Packagist | From 5.0.0-RC1 | 5.3.42 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.5 |
contao/core-bundle Packagist | From 5.4.0-RC1 | 5.6.5 |
Products include Contao Contao.
How do I fix CVE-2025-65961?
Upgrade contao/core-bundle to a fixed version for your release line: 4.13.57, 5.3.42 or 5.6.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-65961 being exploited?
There is no known exploitation of CVE-2025-65961 in the wild and no public exploit code.
Other vulnerabilities in contao
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-68q5-78xp-cwwc.