# CVE-2025-65961: Contao is vulnerable to cross-site scripting in templates

> Attackers can inject malicious scripts into Contao templates, leading to code execution in user browsers.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 25 Nov 2025
- **Also known as:** GHSA-68q5-78xp-cwwc

## What is CVE-2025-65961?

CVE-2025-65961 is a low-severity cross-site scripting vulnerability in contao, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-87 (Improper Neutralization of Alternate XSS Syntax)

## Which versions are affected by CVE-2025-65961?

6 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.13.57 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.13.57 |
| `contao/core-bundle` | Packagist | From 5.0.0-RC1 | 5.3.42 |
| `contao/core-bundle` | Packagist | From 5.0.0-RC1 | 5.3.42 |
| `contao/core-bundle` | Packagist | From 5.4.0-RC1 | 5.6.5 |
| `contao/core-bundle` | Packagist | From 5.4.0-RC1 | 5.6.5 |

Products: Contao Contao.

## How do I fix CVE-2025-65961?

Upgrade contao/core-bundle to a fixed version for your release line: 4.13.57, 5.3.42 or 5.6.5.

## Is CVE-2025-65961 being exploited?

There is no known exploitation of CVE-2025-65961 in the wild and no public exploit code.

## Other vulnerabilities in contao

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65961 and fix it if it is affected.

What it is: CVE-2025-65961 is a low-severity cross-site scripting vulnerability in contao, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65961 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.13.57
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.13.57
- contao/core-bundle (Packagist): affected from 5.0.0-RC1; fixed in 5.3.42
- contao/core-bundle (Packagist): affected from 5.0.0-RC1; fixed in 5.3.42
- contao/core-bundle (Packagist): affected from 5.4.0-RC1; fixed in 5.6.5
- contao/core-bundle (Packagist): affected from 5.4.0-RC1; fixed in 5.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65961/ (Markdown: https://insights.sbomify.com/CVE-2025-65961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65961
- OSV: https://osv.dev/vulnerability/CVE-2025-65961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65961/
Summaries are generated and may contain mistakes; the official description above is the record.
