# CVE-2025-65963: CFiles Unauthorized Folder/ZIP Access in Public Spaces

> Non-member users can create folders and upload/download ZIP archives in public spaces due to insufficient authorization checks in the HumHub CFiles plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Nov 2025
- **Updated:** 26 Nov 2025
- **Also known as:** GHSA-rv2x-7qwp-2hf4

## What is CVE-2025-65963?

CVE-2025-65963 is a medium-severity missing authorization vulnerability in humhub cfiles, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Files is a module for managing files inside spaces and user profiles. Prior to versions 0.16.11 and 0.17.2, insufficient authorization checks allow non-member users to create new folders, up- and download files as a ZIP archive in public spaces. Private spaces are not affected. This issue has been patched in versions 0.16.11 and 0.17.2.

Weakness: CWE-285 (Improper Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-65963?


## How do I fix CVE-2025-65963?

No fix has been published for CVE-2025-65963 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65963 being exploited?

There is no known exploitation of CVE-2025-65963 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65963 and fix it if it is affected.

What it is: CVE-2025-65963 is a medium-severity missing authorization vulnerability in humhub cfiles, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65963 in the wild and no public exploit code.

Affected product: humhub cfiles. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65963/ (Markdown: https://insights.sbomify.com/CVE-2025-65963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65963
- OSV: https://osv.dev/vulnerability/CVE-2025-65963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65963/
Summaries are generated and may contain mistakes; the official description above is the record.
