# CVE-2025-65964: n8n Vulnerable to Remote Code Execution via Git Node Custom Pre-Commit Hook

> Attackers with workflow creation privileges can execute arbitrary code on the host by manipulating Git pre-commit hooks via the Git node.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-wpqc-h9wp-chmq

## What is CVE-2025-65964?

CVE-2025-65964 is a critical code injection vulnerability in N8n N8n, published on 8 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Versions 0.123.1 through 1.119.1 do not have adequate protections to prevent RCE through the project's pre-commit hooks. The Add Config operation allows workflows to set arbitrary Git configuration values, including core.hooksPath, which can point to a malicious Git hook that executes arbitrary commands on the n8n host during subsequent Git operations. Exploitation requires the ability to create or modify an n8n workflow using the Git node. This issue is fixed in version 1.119.2. Workarounds include excluding the Git Node (Docs) and avoiding cloning or interacting with untrusted repositories using the Git Node.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2025-65964?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 0.123.1 | 1.119.2 |
| `n8n` | npm | From 0.123.1 | 1.119.2 |

Products: N8n N8n.

## How do I fix CVE-2025-65964?

Upgrade n8n to 1.119.2 or later.

## Is CVE-2025-65964 being exploited?

There is no known exploitation of CVE-2025-65964 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-65964复现 (github_poc): https://github.com/Syzygy-K/CVE-2025-65964-Exploit
- CVE-2025-65964-poc (github_poc): https://github.com/Anthony558238/CVE-2025-65964-poc
- CVE-2025-65964 (github_poc): https://github.com/Geekby/n8n-CVE-2025-65964
- https://github.com/Saboor-Hakimi-23/CVE-2025-65964 (github_poc): https://github.com/Saboor-Hakimi-23/CVE-2025-65964
- CVE-2025-65964-POC (github_poc): https://github.com/Pinus97/CVE-2025-65964-POC
- CVE-2025-65964 PoC - Malicious Git Hooks (github_poc): https://github.com/nn0nkey/repo

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65964 and fix it if it is affected.

What it is: CVE-2025-65964 is a critical code injection vulnerability in N8n N8n, published on 8 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65964 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected from 0.123.1; fixed in 1.119.2
- n8n (npm): affected from 0.123.1; fixed in 1.119.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65964/ (Markdown: https://insights.sbomify.com/CVE-2025-65964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65964
- OSV: https://osv.dev/vulnerability/CVE-2025-65964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65964/
Summaries are generated and may contain mistakes; the official description above is the record.
