CVE-2025-65966 OneUptime Unauthorized User Creation via API

High 8.8 Published Updated

Low-permission users can create new accounts via direct API requests, bypassing intended interface restrictions in OneUptime.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-65966?

CVE-2025-65966 is a high-severity missing authorization vulnerability in oneuptime, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OneUptime is a solution for monitoring and managing online services. In version 9.0.5598, a low-permission user can create new accounts through a direct API request instead of being restricted to the intended interface. This issue has been patched in version 9.1.0.

Weakness: CWE-285

Which versions are affected by CVE-2025-65966?

2 open source packages ship an affected version, including @oneuptime/common. It affects 1 product.

PackageAffectedFixed in
@oneuptime/common npmAll versions9.1.0
@oneuptime/common npmAll versions9.1.0

Products include Hackerbay Oneuptime.

How do I fix CVE-2025-65966?

Upgrade @oneuptime/common to 9.1.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-65966 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65966 exists.

Sources

Also known as GHSA-m449-vh5f-574g.

Is CVE-2025-65966 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free