# CVE-2025-66001: NeuVector OpenID Connect is vulnerable to man-in-the-middle (MITM)

> Attackers can intercept OpenID Connect authentication traffic due to disabled TLS verification, potentially leading to credential theft or session hijacking.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** GHSA-4jj9-cgqc-x9h5, GO-2025-4235

## What is CVE-2025-66001?

CVE-2025-66001 is a high-severity vulnerability in SUSE neuvector, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NeuVector supports login authentication through OpenID Connect. However, the TLS verification (which verifies the remote server's authenticity and integrity) for OpenID Connect is not enforced by default. As a result this may expose the system to man-in-the-middle (MITM) attacks.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-66001?

3 open source packages ship an affected version, including github.com/neuvector/neuvector.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/neuvector/neuvector` | Go | All versions | None |
| `github.com/neuvector/neuvector` | Go | From 5.3.0 | 5.4.8 |
| `github.com/neuvector/neuvector` | Go | From 5.3.0 | 5.4.8 |

## How do I fix CVE-2025-66001?

Upgrade github.com/neuvector/neuvector to 5.4.8 or later.

## Is CVE-2025-66001 being exploited?

There is no known exploitation of CVE-2025-66001 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66001 and fix it if it is affected.

What it is: CVE-2025-66001 is a high-severity vulnerability in SUSE neuvector, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-66001 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/neuvector/neuvector (Go): affected all versions; no fix listed
- github.com/neuvector/neuvector (Go): affected from 5.3.0; fixed in 5.4.8
- github.com/neuvector/neuvector (Go): affected from 5.3.0; fixed in 5.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66001/ (Markdown: https://insights.sbomify.com/CVE-2025-66001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66001
- OSV: https://osv.dev/vulnerability/CVE-2025-66001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66001/
Summaries are generated and may contain mistakes; the official description above is the record.
