CVE-2025-6601 Business Logic Errors in GitLab

Low 2.7 Published Updated

Authenticated users can gain unauthorized project access by exploiting the access request approval workflow in GitLab EE.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-6601?

CVE-2025-6601 is a low-severity vulnerability in Gitlab Gitlab, published on 27 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.4 before 18.4.3, and 18.5 before 18.5.1 that under certain conditions could have allowed authenticated users to gain unauthorized project access by exploiting the access request approval workflow.

Weakness: CWE-840

Which versions are affected by CVE-2025-6601?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.4.018.4.3, 18.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-6601?

Upgrade gitlab to a fixed version for your release line: 18.4.3 or 18.5.1.

Is CVE-2025-6601 being exploited?

There is no known exploitation of CVE-2025-6601 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-6601, GHSA-28w7-9227-5wcm, UBUNTU-CVE-2025-6601.

Is CVE-2025-6601 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free