{"answers":{"affected":"6 open source packages ship an affected version, including cggmp21 and cggmp24.","exploited":"There is no known exploitation of CVE-2025-66017 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-66017 is a high-severity vulnerability in LFDT-Lockness cggmp21, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66017 and fix it if it is affected.\n\nWhat it is: CVE-2025-66017 is a high-severity vulnerability in LFDT-Lockness cggmp21, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-66017 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cggmp21 (crates.io): affected all versions up to 0.6.3; no fix listed\n- cggmp21 (crates.io): affected all versions up to 0.6.3; no fix listed\n- cggmp21 (crates.io): affected from 0.0.0-0; no fix listed\n- cggmp24 (crates.io): affected all versions; fixed in 0.7.0-alpha.2\n- cggmp24 (crates.io): affected all versions; fixed in 0.7.0-alpha.2\n- cggmp24 (crates.io): affected from 0.0.0-0; fixed in 0.7.0-alpha.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66017/ (Markdown: https://insights.sbomify.com/CVE-2025-66017/index.md)","id":"CVE-2025-66017","markdown":"https://insights.sbomify.com/CVE-2025-66017/index.md","name":"CVE-2025-66017","record":{"aliases":["GHSA-8frv-q972-9rq5","RUSTSEC-2025-0127","RUSTSEC-2025-0128"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust ECDSA TSS library","requires_auth":"none","summary":"Attackers can exploit presignature usage in CGGMP21/24 libraries to significantly reduce cryptographic security, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"CGGMP24 is a state-of-art ECDSA TSS protocol that supports 1-round signing (requires 3 preprocessing rounds), identifiable abort, and a key refresh protocol. In versions 0.6.3 and prior of cggmp21 and version 0.7.0-alpha.1 of cggmp24, presignatures can be used in the way that significantly reduces security. cggmp24 version 0.7.0-alpha.2 release contains API changes that make it impossible to use presignatures in contexts in which it reduces security.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CGGMP21 presignatures can be used in the way that significantly reduces security","id":"CVE-2025-66017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":6,"n_references":2,"next":{"headline":"pypdf manipulated LZWDecode streams can exhaust RAM","id":"CVE-2025-66019"},"packages":[{"ecosystem":"crates.io","fixed":[],"introduced":["0"],"last_affected":["0.6.3"],"package":"cggmp21","purl":null,"source":"GHSA-8frv-q972-9rq5"},{"ecosystem":"crates.io","fixed":[],"introduced":["0"],"last_affected":["0.6.3"],"package":"cggmp21","purl":"pkg:cargo/cggmp21","source":"GHSA-8frv-q972-9rq5"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.0.0-0"],"last_affected":[],"package":"cggmp21","purl":"pkg:cargo/cggmp21","source":"RUSTSEC-2025-0127"},{"ecosystem":"crates.io","fixed":["0.7.0-alpha.2"],"introduced":["0"],"last_affected":[],"package":"cggmp24","purl":null,"source":"GHSA-8frv-q972-9rq5"},{"ecosystem":"crates.io","fixed":["0.7.0-alpha.2"],"introduced":["0"],"last_affected":[],"package":"cggmp24","purl":"pkg:cargo/cggmp24","source":"GHSA-8frv-q972-9rq5"},{"ecosystem":"crates.io","fixed":["0.7.0-alpha.2"],"introduced":["0.0.0-0"],"last_affected":[],"package":"cggmp24","purl":"pkg:cargo/cggmp24","source":"RUSTSEC-2025-0128"}],"prev":{"headline":"CGGMP24 is missing a check in the ZK proof used in CGGMP21","id":"CVE-2025-66016"},"products":["cggmp21"],"published":"2025-11-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-25","vendors":["LFDT-Lockness"]},"summary":"Attackers can exploit presignature usage in CGGMP21/24 libraries to significantly reduce cryptographic security, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2025-66017/"}