{"answers":{"affected":"3 open source packages ship an affected version, including pypdf.","exploited":"There is no known exploitation of CVE-2025-66019 in the wild and no public exploit code.","fix":"Upgrade pypdf to 6.4.0 or later.","what":"CVE-2025-66019 is a medium-severity denial of service vulnerability in py-pdf pypdf, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66019 and fix it if it is affected.\n\nWhat it is: CVE-2025-66019 is a medium-severity denial of service vulnerability in py-pdf pypdf, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-66019 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pypdf (PyPI): affected all versions; fixed in 6.4.0\n- pypdf (PyPI): affected all versions; fixed in 6.4.0\n- pypdf (PyPI): affected all versions; fixed in 6.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66019/ (Markdown: https://insights.sbomify.com/CVE-2025-66019/index.md)","id":"CVE-2025-66019","markdown":"https://insights.sbomify.com/CVE-2025-66019/index.md","name":"CVE-2025-66019","record":{"aliases":["GHSA-m449-cwjh-6pw7","PYSEC-2026-1832","UBUNTU-CVE-2025-66019","openSUSE-SU-2025:15776-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python PDF library","requires_auth":"none","summary":"Attackers can cause excessive memory consumption and potential service disruption by crafting malicious PDFs with LZWDecode streams in pypdf.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"pypdf is a free and open-source pure-python PDF library. Prior to version 6.4.0, an attacker who uses this vulnerability can craft a PDF which leads to a memory usage of up to 1 GB per stream. This requires parsing the content stream of a page using the LZWDecode filter. This issue has been patched in version 6.4.0.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pypdf manipulated LZWDecode streams can exhaust RAM","id":"CVE-2025-66019","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"Valibot has a ReDoS vulnerability in `EMOJI_REGEX`","id":"CVE-2025-66020"},"packages":[{"ecosystem":"PyPI","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"pypdf","purl":null,"source":"GHSA-m449-cwjh-6pw7"},{"ecosystem":"PyPI","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"pypdf","purl":"pkg:pypi/pypdf","source":"GHSA-m449-cwjh-6pw7"},{"ecosystem":"PyPI","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"pypdf","purl":"pkg:pypi/pypdf","source":"PYSEC-2026-1832"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.4.0-1.1"],"introduced":["0"],"last_affected":[],"package":"python-pypdf","purl":"pkg:rpm/opensuse/python-pypdf\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15776-1"}],"prev":{"headline":"CGGMP21 presignatures can be used in the way that significantly reduces security","id":"CVE-2025-66017"},"products":["pypdf"],"published":"2025-11-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-20","vendors":["py-pdf"]},"summary":"Attackers can cause excessive memory consumption and potential service disruption by crafting malicious PDFs with LZWDecode streams in pypdf.","url":"https://insights.sbomify.com/CVE-2025-66019/"}