# CVE-2025-66019: pypdf manipulated LZWDecode streams can exhaust RAM

> Attackers can cause excessive memory consumption and potential service disruption by crafting malicious PDFs with LZWDecode streams in pypdf.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-m449-cwjh-6pw7, PYSEC-2026-1832, UBUNTU-CVE-2025-66019, openSUSE-SU-2025:15776-1

## What is CVE-2025-66019?

CVE-2025-66019 is a medium-severity denial of service vulnerability in py-pdf pypdf, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to version 6.4.0, an attacker who uses this vulnerability can craft a PDF which leads to a memory usage of up to 1 GB per stream. This requires parsing the content stream of a page using the LZWDecode filter. This issue has been patched in version 6.4.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-66019?

3 open source packages ship an affected version, including pypdf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.4.0 |
| `pypdf` | PyPI | All versions | 6.4.0 |
| `pypdf` | PyPI | All versions | 6.4.0 |
| `python-pypdf` | openSUSE:Tumbleweed | All versions | 6.4.0-1.1 |

## How do I fix CVE-2025-66019?

Upgrade pypdf to 6.4.0 or later.

## Is CVE-2025-66019 being exploited?

There is no known exploitation of CVE-2025-66019 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66019 and fix it if it is affected.

What it is: CVE-2025-66019 is a medium-severity denial of service vulnerability in py-pdf pypdf, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66019 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.4.0
- pypdf (PyPI): affected all versions; fixed in 6.4.0
- pypdf (PyPI): affected all versions; fixed in 6.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66019/ (Markdown: https://insights.sbomify.com/CVE-2025-66019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66019
- OSV: https://osv.dev/vulnerability/CVE-2025-66019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66019/
Summaries are generated and may contain mistakes; the official description above is the record.
