# CVE-2025-66020: Valibot has a ReDoS vulnerability in `EMOJI_REGEX`

> Attackers can cause excessive CPU consumption and denial of service via malicious strings in the emoji validation regex.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Nov 2025
- **Updated:** 26 Nov 2025
- **Also known as:** GHSA-vqpr-j7v3-hqw9, MINI-743g-2fw3-hw3q

## What is CVE-2025-66020?

CVE-2025-66020 is a high-severity denial of service vulnerability in open-circle valibot, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Valibot helps validate data using a schema. In versions from 0.31.0 to 1.1.0, the EMOJI_REGEX used in the emoji action is vulnerable to a Regular Expression Denial of Service (ReDoS) attack. A short, maliciously crafted string (e.g., <100 characters) can cause the regex engine to consume excessive CPU time (minutes), leading to a Denial of Service (DoS) for the application. This issue has been patched in version 1.2.0.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-66020?

2 open source packages ship an affected version, including valibot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `valibot` | npm | From 0.31.0 | 1.2.0 |
| `valibot` | npm | From 0.31.0 | 1.2.0 |

## How do I fix CVE-2025-66020?

Upgrade valibot to 1.2.0 or later.

## Is CVE-2025-66020 being exploited?

There is no known exploitation of CVE-2025-66020 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66020 and fix it if it is affected.

What it is: CVE-2025-66020 is a high-severity denial of service vulnerability in open-circle valibot, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66020 in the wild and no public exploit code.

Affected packages and fixed versions:
- valibot (npm): affected from 0.31.0; fixed in 1.2.0
- valibot (npm): affected from 0.31.0; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66020/ (Markdown: https://insights.sbomify.com/CVE-2025-66020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66020
- OSV: https://osv.dev/vulnerability/CVE-2025-66020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66020/
Summaries are generated and may contain mistakes; the official description above is the record.
