{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66022 exists.","fix":"No fix has been published for CVE-2025-66022 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-66022 is a critical vulnerability in factionsecurity faction, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-66022 and fix it if it is affected.\n\nWhat it is: CVE-2025-66022 is a critical vulnerability in factionsecurity faction, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66022 exists.\n\nAffected product: factionsecurity faction. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66022/ (Markdown: https://insights.sbomify.com/CVE-2025-66022/index.md)","id":"CVE-2025-66022","markdown":"https://insights.sbomify.com/CVE-2025-66022/index.md","name":"CVE-2025-66022","record":{"aliases":["GHSA-xr72-2g43-586w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PenTesting Report Framework","requires_auth":"none","summary":"Unauthenticated attackers can upload malicious extensions to the FACTION framework, leading to remote code execution on the server.","user_interaction":"required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"faction","vendor":"owasp"}],"cvss":{"score":9.7,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"FACTION is a PenTesting Report Generation and Collaboration Framework. Prior to version 1.7.1, an extension execution path in Faction’s extension framework permits untrusted extension code to execute arbitrary system commands on the server when a lifecycle hook is invoked, resulting in remote code execution (RCE) on the host running Faction. Due to a missing authentication check on the /portal/AppStoreDashboard endpoint, an attacker can access the extension management UI and upload a malicious extension without any authentication, making this vulnerability exploitable by unauthenticated users. This issue has been patched in version 1.7.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"FACTION Unauthenticated Custom Extension Upload leads to RCE","id":"CVE-2025-66022","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"file_upload","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"NanoMQ has Use-After-Free of malformed bridging message","id":"CVE-2025-66023"},"packages":[],"prev":{"headline":"OWASP Java HTML Sanitizer is vulnerable to XSS via noscript tag and improper style tag sanitization","id":"CVE-2025-66021"},"products":["faction"],"published":"2025-11-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-26","vendors":["factionsecurity"]},"summary":"Unauthenticated attackers can upload malicious extensions to the FACTION framework, leading to remote code execution on the server.","url":"https://insights.sbomify.com/CVE-2025-66022/"}