# CVE-2025-66022: FACTION Unauthenticated Custom Extension Upload leads to RCE

> Unauthenticated attackers can upload malicious extensions to the FACTION framework, leading to remote code execution on the server.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 Nov 2025
- **Updated:** 26 Nov 2025
- **Also known as:** GHSA-xr72-2g43-586w

## What is CVE-2025-66022?

CVE-2025-66022 is a critical vulnerability in factionsecurity faction, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

FACTION is a PenTesting Report Generation and Collaboration Framework. Prior to version 1.7.1, an extension execution path in Faction’s extension framework permits untrusted extension code to execute arbitrary system commands on the server when a lifecycle hook is invoked, resulting in remote code execution (RCE) on the host running Faction. Due to a missing authentication check on the /portal/AppStoreDashboard endpoint, an attacker can access the extension management UI and upload a malicious extension without any authentication, making this vulnerability exploitable by unauthenticated users. This issue has been patched in version 1.7.1.

Weakness: CWE-862 (Missing Authorization), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-66022?

It affects 1 product.


Products: Owasp Faction.

## How do I fix CVE-2025-66022?

No fix has been published for CVE-2025-66022 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66022 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66022 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66022 and fix it if it is affected.

What it is: CVE-2025-66022 is a critical vulnerability in factionsecurity faction, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66022 exists.

Affected product: factionsecurity faction. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66022/ (Markdown: https://insights.sbomify.com/CVE-2025-66022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66022
- OSV: https://osv.dev/vulnerability/CVE-2025-66022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66022/
Summaries are generated and may contain mistakes; the official description above is the record.
