CVE-2025-66024 XWiki Blog Application home page vulnerable to Stored XSS via Post Title

High 8.6 Published Updated

Attackers can inject malicious scripts into blog post titles, leading to session hijacking or privilege escalation for users viewing the posts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-66024?

CVE-2025-66024 is a high-severity cross-site scripting vulnerability in xwiki-contrib application-blog-ui, published on 4 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Versions starting with 9.15 and prior to 9.15.7 are vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. No known workarounds are available.

Weakness: CWE-79

Which versions are affected by CVE-2025-66024?

2 open source packages ship an affected version, including org.xwiki.contrib.blog:application-blog-ui. It affects 1 product.

PackageAffectedFixed in
org.xwiki.contrib.blog:application-blog-ui MavenFrom 9.159.15.7
org.xwiki.contrib.blog:application-blog-ui MavenFrom 9.159.15.7

Products include Xwiki Blog Application.

How do I fix CVE-2025-66024?

Upgrade org.xwiki.contrib.blog:application-blog-ui to 9.15.7 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-66024 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66024 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-h2xq-h7f9-vh6c.

Is CVE-2025-66024 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free