# CVE-2025-66024: XWiki Blog Application home page vulnerable to Stored XSS via Post Title

> Attackers can inject malicious scripts into blog post titles, leading to session hijacking or privilege escalation for users viewing the posts.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-h2xq-h7f9-vh6c

## What is CVE-2025-66024?

CVE-2025-66024 is a high-severity cross-site scripting vulnerability in xwiki-contrib application-blog-ui, published on 4 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Versions starting with 9.15 and prior to 9.15.7 are vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. No known workarounds are available.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66024?

2 open source packages ship an affected version, including org.xwiki.contrib.blog:application-blog-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib.blog:application-blog-ui` | Maven | From 9.15 | 9.15.7 |
| `org.xwiki.contrib.blog:application-blog-ui` | Maven | From 9.15 | 9.15.7 |

Products: Xwiki Blog Application.

## How do I fix CVE-2025-66024?

Upgrade org.xwiki.contrib.blog:application-blog-ui to 9.15.7 or later.

## Is CVE-2025-66024 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66024 exists.

Public exploit code:

- CVE-2025-66024 - XWiki Blog Application home page vulnerable to Stored XSS via Post Title (github_poc): https://github.com/lukasz-rybak/CVE-2025-66024

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66024 and fix it if it is affected.

What it is: CVE-2025-66024 is a high-severity cross-site scripting vulnerability in xwiki-contrib application-blog-ui, published on 4 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66024 exists.

Affected packages and fixed versions:
- org.xwiki.contrib.blog:application-blog-ui (Maven): affected from 9.15; fixed in 9.15.7
- org.xwiki.contrib.blog:application-blog-ui (Maven): affected from 9.15; fixed in 9.15.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66024/ (Markdown: https://insights.sbomify.com/CVE-2025-66024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66024
- OSV: https://osv.dev/vulnerability/CVE-2025-66024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66024/
Summaries are generated and may contain mistakes; the official description above is the record.
