CVE-2025-66030 node-forge ASN.1 OID Integer Truncation

Medium 6.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-66030?

CVE-2025-66030 is a medium-severity vulnerability in digitalbazaar forge, published on 26 Nov 2025.

Official description

Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. An Integer Overflow vulnerability in node-forge versions 1.3.1 and below enables remote, unauthenticated attackers to craft ASN.1 structures containing OIDs with oversized arcs. These arcs may be decoded as smaller, trusted OIDs due to 32-bit bitwise truncation, enabling the bypass of downstream OID-based security decisions. This issue has been patched in version 1.3.2.

Weakness: CWE-190

Which versions are affected by CVE-2025-66030?

2 open source packages ship an affected version, including node-forge. It affects 1 product.

PackageAffectedFixed in
node-forge npmAll versions1.3.2
node-forge npmAll versions1.3.2

Products include Digitalbazaar Forge.

How do I fix CVE-2025-66030?

Upgrade node-forge to 1.3.2 or later.

Is CVE-2025-66030 being exploited?

There is no known exploitation of CVE-2025-66030 in the wild and no public exploit code.

Sources

Also known as AZL-71131, CLEANSTART-2026-VG64993, CLEANSTART-2026-XV88619, DEBIAN-CVE-2025-66030, GHSA-65ch-62r8-g69g, MINI-37m5-m3fm-6jv9 and 14 more.

Is CVE-2025-66030 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free