CVE-2025-66031 node-forge ASN.1 Unbounded Recursion

High 8.7 Published Updated

Remote attackers can cause Denial of Service via stack exhaustion by crafting deep ASN.1 structures in node-forge.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-66031?

CVE-2025-66031 is a high-severity denial of service vulnerability in digitalbazaar forge, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. An Uncontrolled Recursion vulnerability in node-forge versions 1.3.1 and below enables remote, unauthenticated attackers to craft deep ASN.1 structures that trigger unbounded recursive parsing. This leads to a Denial-of-Service (DoS) via stack exhaustion when parsing untrusted DER inputs. This issue has been patched in version 1.3.2.

Weakness: CWE-674

Which versions are affected by CVE-2025-66031?

2 open source packages ship an affected version, including node-forge. It affects 1 product.

PackageAffectedFixed in
node-forge npmAll versions1.3.2
node-forge npmAll versions1.3.2

Products include Digitalbazaar Forge.

How do I fix CVE-2025-66031?

Upgrade node-forge to 1.3.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-66031 being exploited?

There is no known exploitation of CVE-2025-66031 in the wild and no public exploit code.

Sources

Also known as AZL-71134, CLEANSTART-2026-GS11212, CLEANSTART-2026-KB17672, DEBIAN-CVE-2025-66031, GHSA-554w-wpv2-vw27, MINI-2xx9-vpfh-7cr7 and 14 more.

Is CVE-2025-66031 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free