CVE-2025-66034 fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib
Attackers can achieve remote code execution by tricking users into processing a malicious .designspace file with the fontTools varLib script.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-66034?
CVE-2025-66034 is a medium-severity code injection vulnerability in fonttools, published on 29 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
fontTools is a library for manipulating fonts, written in Python. In versions from 4.33.0 to before 4.60.2, the fonttools varLib (or python3 -m fontTools.varLib) script has an arbitrary file write vulnerability that leads to remote code execution when a malicious .designspace file is processed. The vulnerability affects the main() code path of fontTools.varLib, used by the fonttools varLib CLI and any code that invokes fontTools.varLib.main(). This issue has been patched in version 4.60.2.
Weakness: CWE-91
Which versions are affected by CVE-2025-66034?
3 open source packages ship an affected version, including fonttools. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fonttools PyPI | From 4.33.0 | 4.60.2 |
fonttools PyPI | From 4.33.0 | 4.60.2 |
fonttools PyPI | From 4.33.0 | 4.60.2 |
Linux distribution packages (6)
python-FontTools SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.47.2-150600.3.3.1 |
python-FontTools SUSE:Linux Enterprise Server 16.0 | All versions | 4.53.1-160000.3.1 |
python-FontTools SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 4.53.1-160000.3.1 |
python-FontTools openSUSE:Leap 15.6 | All versions | 4.47.2-150600.3.3.1 |
python-FontTools openSUSE:Leap 16.0 | All versions | 4.53.1-160000.3.1 |
python-FontTools openSUSE:Tumbleweed | All versions | 4.61.1-1.1 |
Products include Fonttools Fonttools.
How do I fix CVE-2025-66034?
Upgrade fonttools to 4.60.2 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-66034 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66034 exists.
Public exploit code: 6 proofs of concept on GitHub.
Other vulnerabilities in fonttools
Sources
Also known as BELL-CVE-2025-66034, DEBIAN-CVE-2025-66034, GHSA-768j-98cg-p3fv, PYSEC-2026-1389, SUSE-SU-2026:0199-1, SUSE-SU-2026:20184-1 and 3 more.