CVE-2025-66035 Angular HTTP Client Has XSRF Token Leakage via Protocol-Relative URLs
Attackers can steal XSRF tokens via protocol-relative URLs in Angular HttpClient, enabling CSRF attacks against users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66035?
CVE-2025-66035 is a high-severity vulnerability in angular, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.16, 20.3.14, and 21.0.1, there is a XSRF token leakage via protocol-relative URLs in angular HTTP clients. The vulnerability is a Credential Leak by App Logic that leads to the unauthorized disclosure of the Cross-Site Request Forgery (XSRF) token to an attacker-controlled domain. Angular's HttpClient has a built-in XSRF protection mechanism that works by checking if a request URL starts with a protocol (http:// or https://) to determine if it is cross-origin. If the URL starts with protocol-relative URL (//), it is incorrectly treated as a same-origin request, and the XSRF token is automatically added to the X-XSRF-TOKEN header. This issue has been patched in versions 19.2.16, 20.3.14, and 21.0.1. A workaround for this issue involves avoiding using protocol-relative URLs (URLs starting with //) in HttpClient requests. All backend communication URLs should be hardcoded as relative paths (starting with a single /) or fully qualified, trusted absolute URLs.
Which versions are affected by CVE-2025-66035?
6 open source packages ship an affected version, including @angular/common.
| Package | Affected | Fixed in |
|---|---|---|
@angular/common npm | All versions | 19.2.16 |
@angular/common npm | All versions | 19.2.16 |
@angular/common npm | From 20.0.0-next.0 | 20.3.14 |
@angular/common npm | From 20.0.0-next.0 | 20.3.14 |
@angular/common npm | From 21.0.0-next.0 | 21.0.1 |
@angular/common npm | From 21.0.0-next.0 | 21.0.1 |
How do I fix CVE-2025-66035?
Upgrade @angular/common to a fixed version for your release line: 19.2.16, 20.3.14 or 21.0.1.
Is CVE-2025-66035 being exploited?
There is no known exploitation of CVE-2025-66035 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1773879513, CLSA-2026-1774743848, CLSA-2026-1775176169, CLSA-2026-1775176173, CLSA-2026-1780274973, CLSA-2026-1780274974 and 562 more.