# CVE-2025-66037: OpenSC: Out of Bounds vulnerability

> Crafted input triggers an out-of-bounds heap read in OpenSC, potentially causing crashes or leaking memory contents.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** AZL-81189, BELL-CVE-2025-66037, DEBIAN-CVE-2025-66037, GHSA-m58q-rmjm-mmfx, UBUNTU-CVE-2025-66037

## What is CVE-2025-66037?

CVE-2025-66037 is a low-severity memory corruption vulnerability in Opensc Project Opensc, published on 30 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, feeding a crafted input to the fuzz_pkcs15_reader harness causes OpenSC to perform an out-of-bounds heap read in the X.509/SPKI handling path. Specifically, sc_pkcs15_pubkey_from_spki_fields() allocates a zero-length buffer and then reads one byte past the end of that allocation. This issue has been patched in version 0.27.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-66037?

It affects 1 product.


Products: Opensc Project Opensc.

## How do I fix CVE-2025-66037?

Upgrade to a fixed version.

## Is CVE-2025-66037 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66037 exists.

## Other vulnerabilities in Opensc Project Opensc

- [CVE-2021-34193](https://insights.sbomify.com/CVE-2021-34193/): Memory corruption in n/a (high 7.5)
- [CVE-2019-16058](https://insights.sbomify.com/CVE-2019-16058/): Memory corruption in n/a (high 7.5)
- [CVE-2019-6502](https://insights.sbomify.com/CVE-2019-6502/): Denial of service in n/a (high 7.5)
- [CVE-2023-2977](https://insights.sbomify.com/CVE-2023-2977/): Memory corruption in OpenSC (high 7.1)
- [CVE-2019-20792](https://insights.sbomify.com/CVE-2019-20792/): Use after free in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66037 and fix it if it is affected.

What it is: CVE-2025-66037 is a low-severity memory corruption vulnerability in Opensc Project Opensc, published on 30 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66037 exists.

Affected product: Opensc Project Opensc. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66037/ (Markdown: https://insights.sbomify.com/CVE-2025-66037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66037
- OSV: https://osv.dev/vulnerability/CVE-2025-66037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66037/
Summaries are generated and may contain mistakes; the official description above is the record.
