# CVE-2025-66040: Spotipy has a XSS vulnerability in OAuth callback server

> Attackers can execute arbitrary JavaScript in users' browsers via unsanitized error parameters in the Spotipy OAuth callback server.

- **Severity:** Low 3.6 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Nov 2025
- **Updated:** 28 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-66040, GHSA-r77h-rpp9-w2xm, PYSEC-2026-1937, UBUNTU-CVE-2025-66040, openSUSE-SU-2025:15777-1

## What is CVE-2025-66040?

CVE-2025-66040 is a low-severity cross-site scripting vulnerability in spotipy-dev spotipy, published on 26 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66040?

3 open source packages ship an affected version, including spotipy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spotipy` | PyPI | All versions | 2.25.2 |
| `spotipy` | PyPI | All versions | 2.25.2 |
| `spotipy` | PyPI | All versions | 2.25.2 |
| `python-spotipy` | openSUSE:Tumbleweed | All versions | 2.25.2-1.1 |

## How do I fix CVE-2025-66040?

Upgrade spotipy to 2.25.2 or later.

## Is CVE-2025-66040 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66040 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66040 and fix it if it is affected.

What it is: CVE-2025-66040 is a low-severity cross-site scripting vulnerability in spotipy-dev spotipy, published on 26 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66040 exists.

Affected packages and fixed versions:
- spotipy (PyPI): affected all versions; fixed in 2.25.2
- spotipy (PyPI): affected all versions; fixed in 2.25.2
- spotipy (PyPI): affected all versions; fixed in 2.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66040/ (Markdown: https://insights.sbomify.com/CVE-2025-66040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66040
- OSV: https://osv.dev/vulnerability/CVE-2025-66040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66040/
Summaries are generated and may contain mistakes; the official description above is the record.
