CVE-2025-66168 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound
An integer overflow in MQTT packet decoding allows unexpected broker behavior, requiring MQTT transport connectors to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66168?
CVE-2025-66168 is a medium-severity vulnerability in Apache Activemq, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
WARNING:
Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases.
See the following for more details: https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt https://www.cve.org/CVERecord?id=CVE-2026-40046
Original Report:
Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted.
This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0
Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.
Weakness: CWE-190
Which versions are affected by CVE-2025-66168?
19 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-mqtt. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-all Maven | All versions | 5.19.2 |
org.apache.activemq:activemq-all Maven | All versions | 5.19.2 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.1.9 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.1.9 |
org.apache.activemq:activemq-all Maven | From 6.2.0 | 6.2.1 |
org.apache.activemq:activemq-all Maven | From 6.2.0 | 6.2.1 |
13 more packages
activemq Bitnami | All versions | 5.19.2, 6.1.9, 6.2.1 |
org.apache.activemq:activemq-mqtt Maven | All versions | 5.19.2 |
org.apache.activemq:activemq-mqtt Maven | All versions | 5.19.2 |
org.apache.activemq:activemq-mqtt Maven | From 6.0.0 | 6.1.9 |
org.apache.activemq:activemq-mqtt Maven | From 6.0.0 | 6.1.9 |
org.apache.activemq:activemq-mqtt Maven | From 6.2.0 | 6.2.1 |
org.apache.activemq:activemq-mqtt Maven | From 6.2.0 | 6.2.1 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.2 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.2 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.1.9 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.1.9 |
org.apache.activemq:apache-activemq Maven | From 6.2.0 | 6.2.1 |
org.apache.activemq:apache-activemq Maven | From 6.2.0 | 6.2.1 |
Products include Apache Activemq.
How do I fix CVE-2025-66168?
Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.2, 6.1.9 or 6.2.1.
Is CVE-2025-66168 being exploited?
There is no known exploitation of CVE-2025-66168 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2025-66168, DEBIAN-CVE-2025-66168, GHSA-c825-6ph3-4h84, MINI-5r4w-mrf3-qx8x, MINI-97j5-568x-vw27, MINI-fx38-h72q-qmh9 and 11 more.