# CVE-2025-66168: Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound

> An integer overflow in MQTT packet decoding allows unexpected broker behavior, requiring MQTT transport connectors to be enabled.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 10 Apr 2026
- **Also known as:** BIT-activemq-2025-66168, DEBIAN-CVE-2025-66168, GHSA-c825-6ph3-4h84, MINI-5r4w-mrf3-qx8x, MINI-97j5-568x-vw27, MINI-fx38-h72q-qmh9, MINI-p93g-jw37-gfv9, OESA-2026-1607, OESA-2026-1608, OESA-2026-1609, OESA-2026-1610, OESA-2026-1611, OESA-2026-1679, OESA-2026-1680, OESA-2026-1681, ROOT-APP-MAVEN-CVE-2025-66168, UBUNTU-CVE-2025-66168

## What is CVE-2025-66168?

CVE-2025-66168 is a medium-severity vulnerability in Apache Activemq, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

WARNING:

Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases.

See the  following for more details:
 https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt 
 https://www.cve.org/CVERecord?id=CVE-2026-40046 

Original Report:

Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted.

This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0

Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2025-66168?

19 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-mqtt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.2 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.2 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.1.9 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.1.9 |
| `org.apache.activemq:activemq-all` | Maven | From 6.2.0 | 6.2.1 |
| `org.apache.activemq:activemq-all` | Maven | From 6.2.0 | 6.2.1 |
| `activemq` | Bitnami | All versions | 5.19.2, 6.1.9, 6.2.1 |
| `org.apache.activemq:activemq-mqtt` | Maven | All versions | 5.19.2 |
| `org.apache.activemq:activemq-mqtt` | Maven | All versions | 5.19.2 |
| `org.apache.activemq:activemq-mqtt` | Maven | From 6.0.0 | 6.1.9 |
| `org.apache.activemq:activemq-mqtt` | Maven | From 6.0.0 | 6.1.9 |
| `org.apache.activemq:activemq-mqtt` | Maven | From 6.2.0 | 6.2.1 |
| `org.apache.activemq:activemq-mqtt` | Maven | From 6.2.0 | 6.2.1 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.2 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.2 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.1.9 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.1.9 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.2.0 | 6.2.1 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.2.0 | 6.2.1 |

Products: Apache Activemq.

## How do I fix CVE-2025-66168?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.2, 6.1.9 or 6.2.1.

## Is CVE-2025-66168 being exploited?

There is no known exploitation of CVE-2025-66168 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66168 and fix it if it is affected.

What it is: CVE-2025-66168 is a medium-severity vulnerability in Apache Activemq, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66168 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.2
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.2
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.1.9
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.1.9
- org.apache.activemq:activemq-all (Maven): affected from 6.2.0; fixed in 6.2.1
- org.apache.activemq:activemq-all (Maven): affected from 6.2.0; fixed in 6.2.1
- activemq (Bitnami): affected all versions; fixed in 5.19.2, 6.1.9, 6.2.1
- org.apache.activemq:activemq-mqtt (Maven): affected all versions; fixed in 5.19.2
- org.apache.activemq:activemq-mqtt (Maven): affected all versions; fixed in 5.19.2
- org.apache.activemq:activemq-mqtt (Maven): affected from 6.0.0; fixed in 6.1.9
- org.apache.activemq:activemq-mqtt (Maven): affected from 6.0.0; fixed in 6.1.9
- org.apache.activemq:activemq-mqtt (Maven): affected from 6.2.0; fixed in 6.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66168/ (Markdown: https://insights.sbomify.com/CVE-2025-66168/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66168
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66168
- OSV: https://osv.dev/vulnerability/CVE-2025-66168

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66168/
Summaries are generated and may contain mistakes; the official description above is the record.
