# CVE-2025-66169: Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component

> Attackers can inject malicious Cypher queries into the Apache Camel Neo4j component, potentially reading or modifying database data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2026
- **Updated:** 15 Jan 2026
- **Also known as:** GHSA-4jrw-64vr-7g8m

## What is CVE-2025-66169?

CVE-2025-66169 is a medium-severity SQL injection vulnerability in Apache Camel, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cypher Injection vulnerability in Apache Camel camel-neo4j component.

This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0

Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-66169?

6 open source packages ship an affected version, including org.apache.camel:camel-neo4j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-neo4j` | Maven | From 4.10.0 | 4.10.8 |
| `org.apache.camel:camel-neo4j` | Maven | From 4.10.0 | 4.10.8 |
| `org.apache.camel:camel-neo4j` | Maven | From 4.14.0 | 4.14.3 |
| `org.apache.camel:camel-neo4j` | Maven | From 4.14.0 | 4.14.3 |
| `org.apache.camel:camel-neo4j` | Maven | From 4.15.0 | 4.17.0 |
| `org.apache.camel:camel-neo4j` | Maven | From 4.15.0 | 4.17.0 |

Products: Apache Camel.

## How do I fix CVE-2025-66169?

Upgrade org.apache.camel:camel-neo4j to a fixed version for your release line: 4.10.8, 4.14.3 or 4.17.0.

## Is CVE-2025-66169 being exploited?

There is no known exploitation of CVE-2025-66169 in the wild and no public exploit code.

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66169 and fix it if it is affected.

What it is: CVE-2025-66169 is a medium-severity SQL injection vulnerability in Apache Camel, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66169 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-neo4j (Maven): affected from 4.10.0; fixed in 4.10.8
- org.apache.camel:camel-neo4j (Maven): affected from 4.10.0; fixed in 4.10.8
- org.apache.camel:camel-neo4j (Maven): affected from 4.14.0; fixed in 4.14.3
- org.apache.camel:camel-neo4j (Maven): affected from 4.14.0; fixed in 4.14.3
- org.apache.camel:camel-neo4j (Maven): affected from 4.15.0; fixed in 4.17.0
- org.apache.camel:camel-neo4j (Maven): affected from 4.15.0; fixed in 4.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66169/ (Markdown: https://insights.sbomify.com/CVE-2025-66169/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66169
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66169
- OSV: https://osv.dev/vulnerability/CVE-2025-66169

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66169/
Summaries are generated and may contain mistakes; the official description above is the record.
