CVE-2025-66170 Apache CloudStack: Any user can list backups that they should not have access to

Medium 6.5 Published Updated

Authenticated users can list backups from other accounts in Apache CloudStack when the Backup plugin is enabled, exposing backup metadata.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-66170?

CVE-2025-66170 is a medium-severity missing authorization vulnerability in Apache Cloudstack, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and has access to specific APIs can list backups from any account in the environment. This vulnerability does not allow them to see the contents of the backup.

Users are recommended to upgrade to version 4.22.0.1, which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2025-66170?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2025-66170?

No fix has been published for CVE-2025-66170 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-66170 being exploited?

There is no known exploitation of CVE-2025-66170 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-7p28-jcmx-86m5.

Is CVE-2025-66170 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free