CVE-2025-66172 Apache CloudStack: Any user can attach a volume in their VMs from backups they should not have access to

High 8.1 Published Updated

Authenticated users can restore and attach volumes from other users' backups due to improper access logic in the Backup plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-66172?

CVE-2025-66172 is a high-severity missing authorization vulnerability in Apache Cloudstack, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can restore a volume from any other user's backups and attach the volume to their own VMs.

Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.

Weakness: CWE-359

Which versions are affected by CVE-2025-66172?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2025-66172?

No fix has been published for CVE-2025-66172 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-66172 being exploited?

There is no known exploitation of CVE-2025-66172 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-jp26-gvwc-cc96.

Is CVE-2025-66172 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free