CVE-2025-66200 Apache HTTP Server: mod_userdir+suexec bypass via AllowOverride FileInfo
Attackers with htaccess access can execute CGI scripts as unexpected users via mod_userdir and suexec bypass, requiring an upgrade to Apache HTTP Server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66200?
CVE-2025-66200 is a medium-severity vulnerability in Apache Http Server, published on 5 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
mod_userdir+suexec bypass via AllowOverride FileInfo vulnerability in Apache HTTP Server. Users with access to use the RequestHeader directive in htaccess can cause some CGI scripts to run under an unexpected userid.
This issue affects Apache HTTP Server: from 2.4.7 through 2.4.65.
Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Weakness: CWE-288
Which versions are affected by CVE-2025-66200?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.7 | 2.4.66 |
Products include Apache Http Server.
How do I fix CVE-2025-66200?
Upgrade apache to 2.4.66 or later.
Is CVE-2025-66200 being exploited?
There is no known exploitation of CVE-2025-66200 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2025-66200, AZL-71528, AZL-71590, BELL-CVE-2025-66200, BIT-apache-2025-66200, DEBIAN-CVE-2025-66200 and 3 more.