# CVE-2025-66200: Apache HTTP Server: mod_userdir+suexec bypass via AllowOverride FileInfo

> Attackers with htaccess access can execute CGI scripts as unexpected users via mod_userdir and suexec bypass, requiring an upgrade to Apache HTTP Server.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** ALPINE-CVE-2025-66200, AZL-71528, AZL-71590, BELL-CVE-2025-66200, BIT-apache-2025-66200, DEBIAN-CVE-2025-66200, GHSA-3j3g-3pw9-9vcc, MINI-r99p-x6v3-772r, UBUNTU-CVE-2025-66200

## What is CVE-2025-66200?

CVE-2025-66200 is a medium-severity vulnerability in Apache Http Server, published on 5 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

mod_userdir+suexec bypass via AllowOverride FileInfo vulnerability in Apache HTTP Server. Users with access to use the RequestHeader directive in htaccess can cause some CGI scripts to run under an unexpected userid.

This issue affects Apache HTTP Server: from 2.4.7 through 2.4.65.

Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-66200?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.7 | 2.4.66 |

Products: Apache Http Server.

## How do I fix CVE-2025-66200?

Upgrade apache to 2.4.66 or later.

## Is CVE-2025-66200 being exploited?

There is no known exploitation of CVE-2025-66200 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66200 and fix it if it is affected.

What it is: CVE-2025-66200 is a medium-severity vulnerability in Apache Http Server, published on 5 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66200 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.7; fixed in 2.4.66

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66200/ (Markdown: https://insights.sbomify.com/CVE-2025-66200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66200
- OSV: https://osv.dev/vulnerability/CVE-2025-66200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66200/
Summaries are generated and may contain mistakes; the official description above is the record.
