{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66201 exists.","fix":"No fix has been published for CVE-2025-66201 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-66201 is a high-severity server-side request forgery vulnerability in Librechat Librechat, published on 29 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66201 and fix it if it is affected.\n\nWhat it is: CVE-2025-66201 is a high-severity server-side request forgery vulnerability in Librechat Librechat, published on 29 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66201 exists.\n\nAffected product: Librechat Librechat. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66201/ (Markdown: https://insights.sbomify.com/CVE-2025-66201/index.md)","id":"CVE-2025-66201","markdown":"https://insights.sbomify.com/CVE-2025-66201/index.md","name":"CVE-2025-66201","record":{"aliases":["GHSA-7m2q-fjwr-5x8v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"LibreChat web application","requires_auth":"low_privilege","summary":"Authenticated users can exploit SSRF in LibreChat's Actions feature to access internal server resources and potentially impersonate the server.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"librechat","vendor":"librechat"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its \"Actions\" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata services, through which impersonation of the server might be possible). This issue has been patched in version 0.8.1-rc2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"LibreChat is Vulnerable to Server-Side Request Forgery (SSRF) in Actions Capability","id":"CVE-2025-66201","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"librechat:librechat","products":["librechat:librechat"],"type":"ssrf","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Astro has an Authentication Bypass via Double URL Encoding, a bypass for CVE-2025-64765","id":"CVE-2025-66202"},"packages":[],"prev":{"headline":"Apache HTTP Server: mod_userdir+suexec bypass via AllowOverride FileInfo","id":"CVE-2025-66200"},"products":["LibreChat"],"published":"2025-11-29","related":[{"cvss_score":9.6,"headline":"LibreChat Exfiltrates Server Secrets via MCP Server URL Injection","id":"CVE-2026-32625","kev_date_added":null,"published":"2026-06-02"},{"cvss_score":9.4,"headline":"Improper Access Control in danny-avila/librechat","id":"CVE-2024-11167","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"LibreChat MCP Stdio Remote Command Execution","id":"CVE-2026-22252","kev_date_added":null,"published":"2026-01-12"},{"cvss_score":9.1,"headline":"LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions","id":"CVE-2025-69222","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":9.1,"headline":"Path traversal in n/a","id":"CVE-2024-41704","kev_date_added":null,"published":"2024-07-22"},{"cvss_score":8.8,"headline":"Path Traversal in danny-avila/librechat","id":"CVE-2024-11170","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":8.6,"headline":"LibreChat JSON Injection in Chat POST Allows Remote Resource Inclusion and PXSS via Image Upload","id":"CVE-2025-66450","kev_date_added":null,"published":"2025-12-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-01","vendors":["danny-avila"]},"summary":"Authenticated users can exploit SSRF in LibreChat's Actions feature to access internal server resources and potentially impersonate the server.","url":"https://insights.sbomify.com/CVE-2025-66201/"}