# CVE-2025-66201: LibreChat is Vulnerable to Server-Side Request Forgery (SSRF) in Actions Capability

> Authenticated users can exploit SSRF in LibreChat's Actions feature to access internal server resources and potentially impersonate the server.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Nov 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-7m2q-fjwr-5x8v

## What is CVE-2025-66201?

CVE-2025-66201 is a high-severity server-side request forgery vulnerability in Librechat Librechat, published on 29 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata services, through which impersonation of the server might be possible). This issue has been patched in version 0.8.1-rc2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-66201?

It affects 1 product.


Products: Librechat Librechat.

## How do I fix CVE-2025-66201?

No fix has been published for CVE-2025-66201 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66201 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66201 exists.

## Other vulnerabilities in Librechat Librechat

- [CVE-2026-32625](https://insights.sbomify.com/CVE-2026-32625/): LibreChat Exfiltrates Server Secrets via MCP Server URL Injection (critical 9.6)
- [CVE-2024-11167](https://insights.sbomify.com/CVE-2024-11167/): Improper Access Control in danny-avila/librechat (critical 9.4)
- [CVE-2026-22252](https://insights.sbomify.com/CVE-2026-22252/): LibreChat MCP Stdio Remote Command Execution (critical 9.1)
- [CVE-2025-69222](https://insights.sbomify.com/CVE-2025-69222/): LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions (critical 9.1)
- [CVE-2024-41704](https://insights.sbomify.com/CVE-2024-41704/): Path traversal in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66201 and fix it if it is affected.

What it is: CVE-2025-66201 is a high-severity server-side request forgery vulnerability in Librechat Librechat, published on 29 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66201 exists.

Affected product: Librechat Librechat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66201/ (Markdown: https://insights.sbomify.com/CVE-2025-66201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66201
- OSV: https://osv.dev/vulnerability/CVE-2025-66201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66201/
Summaries are generated and may contain mistakes; the official description above is the record.
